欢迎光临
我们一直在努力
"

CentOS 6.4 安装搭建 Scrapy 0.22 环境

 一、安装Python2.7.6

二、解决Yum不支持Python2.7的问题
三、安装setuptools 和 pip
四、安装libxslt-devel支持lxml
五、安装Scrapy

一、安装Python2.7.6

  1. 更新CentOS lib库文件
  2. 安装开发工具包
  3. 安装扩展包
  4. 下载Python2.7.6
  5. 解压Python2.7.6
  6. 进入Python2.7.6目录
  7. 编译安装Python2.7.6

二、解决Yum不支持Python2.7的问题

  1. 将老的Python程序进行备份
  2. 建立新的Python链接
  3. 修改/usr/bin/yum文件

    将第一行的 #!/usr/bin/python 改为 #!/usr/bin/python2.6.6

    10212511-3KO4

三、安装setuptools 和 pip

  1. 下载setuptools

  2. 解压setuptools

  3. 进入setuptools目录

  4. 通过已安装的Python2.7.6安装setuptools

  5. 安装 pip

 

四、安装libxslt-devel支持lxml

五、安装Scrapy

可能遇到的报错:
http://www.legendsec.org/1346.html
在Linux CentOS 6.6上安装Python 2.7.9
http://www.legendsec.org/1341.html
 ImportError: No module named PIL

http://blog.chinaunix.net/uid-20776139-id-4160486.html

pip install flask

转载请注明: 转载自Legend‘s BLog

本文链接地址: CentOS 6.4 安装搭建 Scrapy 0.22 环境



未经允许不得转载:Legend‘s BLog » CentOS 6.4 安装搭建 Scrapy 0.22 环境

分享到:更多 ()

发表评论

电子邮件地址不会被公开。 必填项已用*标注

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据

无觅相关文章插件,快速提升流量